GPU load only around 50%?!



  • Hey there,
    Trying out Altus with redshift render, and everything looks great. I can even denoise all my aov and comp them back, and for some reason I get more detail comparing to simply denoise my beauty pass. Very nice software.
    I have GTX1070 which computes fairly fast, but I noticed that gpu loading only reaches 50-60%. Does that mean I should fire two jobs at the same to fully utilize GTX1070?

    One more thing, can anyone direct me which OpenCL driver I need to install on Win7? I want to test out CPU+GPU computing speed. But I just don't which driver to install.

    Best,

    Han


  • administrators

    Hrm, you shouldn't get more detail denoising all AOVs versus just denoising beauty…

    What dimension images are you filtering? On small images (some of the images in our test suite are are qHD, i.e. 960x540) the GPU portion of Altus completes in a few seconds, so the GPU never gets to ramp up. It very much depends on your scenes and images, but sure, if you can run more instances on the GTX1070, then do.

    For best performance with a (rare) risk of artifacts, you want the Intel OpenCL runtime: https://software.intel.com/en-us/articles/opencl-drivers#latest_CPU_runtime

    The AMD OpenCL ICD, available as part of the AMD App SDK, is also an option, that we've never had problems with: http://developer.amd.com/tools-and-sdks/opencl-zone/amd-accelerated-parallel-processing-app-sdk/



  • @samat.io
    Thanks for the link.
    My test is on 1280x720, and the final will be in HD. I notice more hightlight detail in my comp with all Aovs. But, it could be differences between Redshift AOVs and beauty. I will take a look later.


  • administrators

    Any chance you could shoot those images over to support@innobright? We'd love to take a look at them.

    So, a 720p image may be small enough (especially if it has black space) to run so quickly on a GTX 1070 that the GPU never spins up. Depending on how many AOVs you have you could probably filter 3–4 images at the same time on a card w/ 8 GiB RAM, as Altus is typically memory limited.


Log in to reply
 

Looks like your connection to Innobright Forums was lost, please wait while we try to reconnect.